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Audience

» Executive level
» But line and staff are still welcome

» Non-technical
« Staff trying to sell PHP up stream

- Manager looking to understand the business value of PHP
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Agenda

« Top 5 reasons for modernization
» Green to web
» Extend DB2 Data and Programs
» Web Services
» New Applications
» Consolidate Data to DB2
« Why PHP?
- How do we get there?

» PHP Development Roadmap

» Resources
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Questions?

- Let’s keep it interactive!

» Follow us!
n » http://bit.ly/cjueZg (Zend Technologies or search for Zend)

» http://twitter.com/zend
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Why PHP on i?

Leverage Existing

Infrastructure to

Develop & Run Dynamic
Web Applications Easily

» Powerful , Flexible, & Fastest Growing Web
Development Language

* Native on IBM i/0S

» Backing & Support of IBM

» Controlled/Driven by PHP Community

» Easy to Use & Fast to Deploy

» Supports Heterogeneous Environments

» Powerful Integration Capabilities

application

business logic without rewriting

Application Modernization Access RPG Consolidate Data in
Use PHP to web-enable green screen Programs & Data as DB2/400
applications, utilizing existing data & Web Services Move PHP applications that are

running on Windows or Linux
that access data in DB2 to run
in IBM i/OS to speed up or

Package programs and data as
web services and make
available to other web

reduce complexity of the

applications S
applications
Access DB2/400 Data New/Packaged Web
via Browser Application on IBM i/OS
Easily access and interact with Create new applications with PHP on
DB2/400 data using a standard IBM i/OS or leverage thousands of
web browser existing Open Sources applications

‘pd
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1) Green to the web

» Green is good

» There is nothing wrong with a solid 5250 application
» If it works and users are productive & satisfied, don’t change it!
» Great for transactional processing
» Challenges
» No native GUI interface
» Limited number of colors (no, reverse image is not a color!)
» Limited real estate
» Slightly higher learning curve
» Simply looks old, but stable!
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1) Green to the web

*Web is better?

» User learning curve is shorter in the web

» Technology mature and stable

» Nearly everyone can operate a browser

» Can be aesthetically pleasing

»Web 2.0 & HTML5 - closing gap on Fat Client Experience
» The new boss has never worked with a text interface...

...and has no plans to start now!
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Allied Beverages

« Background
» Exclusive liquor distributor on East Coast.

- Challenge
» Increase industry leadership through superior customer service
» Establish e-Commerce and mobile site to support distribution
» Integrate with IBM i

 Solution
» Implemented PHP natively while simultaneously utilizing legacy code and data.
» Leverage Web 2.0 and Zend Framework to build eBiz site

- Benefits
» Development time was lower than estimated and shorter than considered alternatives
» Doubled the speed of eBiz by utilizing Zend Server
» Site won 2009 IBM COMMON Innovation Award
» No additional hardware required to implement solution
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2) DB2 Data & Program Accessibility

-Data is a great place to start

» Executive dashboards Information Management

» Drill down analysis
» Access to mountains of statistics and transactional information
» Real estate limitations broken
- What about programs?
» 30+ years of business Logic
» Solid and dependable routines
» Stored procedures make programs available like data
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Corvette America

- Background

» Leading manufacturer of Corvette interiors and supplier of aftermarket parts
and accessories for Corvette dealers and owners who may be buying, selling,
restoring or accessorizing a vintage or late model Corvette.

- Challenges corvette '

» To maintain lean, efficient central operations while providing fast and America T
impeccable service to a 3,000-member dealer network with a worldwide —
customer base

» Driving more processes online to provide a superior business experience for both
dealers and customers.Manual, time-consuming order sourcing and fulfillment
process.

» Solution

» Zend PHP solutions helped Corvette America’s IT group extend the capabilities
of its e-commerce application, quickly and cost-effectively, on IBM i.

« Benefits

» Leveraged existing business logic in pricing routines without need for
complicated code re-write.

» Collaborative development approach has team working together

» Accelerated dealer sales process while improving the efficiency of managing the
supply chain.

© All rights reserved. Zend Technologies, Inc.
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3) Web Services...

What are they?

» Small pieces loosely coupled...
» Self described computer programs communicating

*B2B processing and even some B2C

» GPS maps & Weather integration

» Trading Partners (Remember EDI)?

» Amazon, Yahoo, Google

» Can exist Intra-system as well as Inter-system
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3) Web Services...

«Extend DB2 Data and Programs

» EXpose pricing
> Service

» Available over the internet and in secured communications

» Real time access to inventory
» Product details

» Many more possibilities

- Great equalizer
» Platform and language agnostic

» You are probably using them today and don’t realize it!
e Many search features like iPhone use web services
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4) New Applications...
-Pre-Packaged

» Who is writing new applications for IBM i?

» What languages are they using?

» Consolidation does not need to happen on Intel!

» MySQL and PHP extend IBM i with thousands of applications

@ Upenrro
u Thoodle
Magento & Joomlal
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4) New Applications...

«Home Grown

» Brand new applications created from scratch

» Integrating new applications with legacy functionality

e Program calls
« DB2 Data
» Native IBM i resources like data queues, user spaces and spooled files

© All rights reserved. Zend Technologies, Inc.
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Arrowcast, Inc. - Supplier Portal

- Background

» 210,000 square foot foundry situated on 40 acres in Shawano, Wisconsin;
provide quality engineered cast metal components worldwide;
with US Government, John Deere, Case.

- Challenges
» Manual, time-consuming order sourcing and fulfillment process.
» Disparate data (Excel, Access, MSSQL, DB2) on multiple platforms
(Windows & IBM i)

» Solution

» Developed PHP-based supplier portal: vendors log on, view only BOM
components they are authorized to quote on; electronic PO process and tracking

» Enabled Aarrowcast to consolidate information off of non-System | platforms
and databases onto the System | where it originates.

« Benefits

» Supplier Portal helped modernize how they work with suppliers which resulted
in higher revenues and improved customer service levels & response time

» Exposed legacy information to vendors in self service model

» Improved utilization of existing System i infrastructure

» Improved delivery quality - went from 50% on time delivery to 90-95%

© All rights reserved. Zend Technologies, Inc.
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5) Consolidate Data on IBM i

 Why consolidate?
» Rock solid architecture
» Accessible via fully implemented TCP/IP stack at IPv4 & IPvé
» Mature and dynamic technology
» Strategic for IBM
» PHP can enable virtually any application
» Customers are bringing data back to the central repository
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Risks

» But let’s say a change is needed, look at risks!

» “Process Collapse” cited for #1 cause of failed migrations

e This is where all the risk is.

« >60% of ERP implementation starts fail (Rockford Consulting, 2010)
» Moral of the story?

e Ensure that you and the team understand why a change is required
e Then get behind it!
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Key Priorities articulated by CTOs, ClOs and
VPs of Engineering

» Leverage investment in IBM i infrastructure
» Expose DB2/400 data via the web
» Webify green screen applications for end-users
» Maximize leverage of Power Systems computing power
» Move Windows/Linux based PHP apps to IBM i
» Deploy new web based applications

» Mitigate and minimize risk/cost of migrations

» Retool RPG programmers and access lower cost development
resources to address business needs

» Leverage benefits of open-source technologies - create

portable applications

2/25
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Why PHP?
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Why PHP on IBM i?

. Low Learning Curve

Easy Integration into
Heterogeneous Environments

Robust, Multi-Platform,
High-Performance, Scalable, Secure

Vibrant Community

Rapid
Innovation

Run an
Agile
Business

Proven
Deployment

/201 © All rights reserved. Zend Technologies, Inc.
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PHP Adoption

Gartner Hype Cycle

Peak of Inflated Expectations

Plateau of Productivity

p———r

Slope of Enlightenment

Trough of Disillugionment

Technology Trigger
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Maturity

« PHP was born with & continues a procedural look and feel
« PHP supports an Object Oriented model

« Frameworks written in PHP

o smarty.
» Zend Framework, Smarty, Symfony, more... TEMPLATE ENGINE
e Thriving community e 7END

# FRAMEWORK
» Millions of developers

» Enterprise growing rapidly (Gartner: 2.5 Million+ by 2014)
- Thousands of applications

» Sourceforge search returns 18,800 hits
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Enterprise PHP Adoption is Growing Rapidly

PHP
Developers

5M

aM

3M

2M

1M

2009 2014

Non-commercial developers

' ‘ Commercial and corporate IT developers

Gartner Research Note: “PHP: Past, Present and Future”, Dec. 2", 2009

© All rights reserved. Zend Technologies, Inc.

Gartner

“Commercial and corporate IT
developers will account for more
than 2 million PHP community
members—growing from 20% to
50% of the worldwide PHP
developer population.”
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Top 10 Internet Sites by WW traffic

1. Google.com 8. Blogger.com
— e > a—
= = . ﬁ Y i
= 2. Facebook.com e 7. Baidu.com
' o B
gt 3. Youtube.com onta 6. Wikipedia.com
— |
= = : = —
=5 - :I‘ .
» F 4, Yahoo.com 9. twitter.com

5. Live.com

€)Alexa

The Web Information Company
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How do we get there?




Education

« PHP is one of the easiest languages to learn

» ...but requires some effort to master!
» The process can be very organic and resources abound
« How do we start?

» Next month Webcast is entitiled:
e Getting Started with PHP for IBM

 Assess the landscape...
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Education

 Look at the skills of current staff and...
» Should some folks begin with procedural
» Some with OO experience can start there or
» Significant OO experience can move quickly into Frameworks

 Let’s look at the Zend Roadmap for PHP

‘@ E = Store | Forums | by Account | Signout | == OEE DN | Search [l

" The PHP Company

zend 2, Downloads B Mewsletter OSuppun B4 Contact

Selutions Products  Services Downloads Community Resources Company Online Store Support Center

Home J Services f Zend PHP Training

Global Senices
PHP Consulting

PHF Cerification

training

PURCHASE

PHP Training > - e
Zend Training Bundles
Course Catalog Zend PHP Training Courses
Training Units » Purchase Now
Registration Infarmatian Expand Your Knowledge on PHP and Zend Products
FaG » Contact Sales
Here at Zend's Training Departrent, our mission is to provide relevant and engaging learning
Training Partners » Chat with Sales
opportunities — from the basics, through culting edge topics, and on to cerification - advancing
Meet Our Instructars

) the knowledge and success of our PHP colleagues, and the wider Open Source community,
Online Training Schedule

glisezrfluem Training "You cannot keach a man anything; you can anly help him find i within himsell"- Galffeo Gakfel » Yiew Course Schedule

» heet our Instructors

Each course offers real-life examples and interactivity to provide a robust and hands-on
training experience, to sharpen your existing skills or add new skills. You can take our courses
onling, In a classroom setting or onsite (availability based on geography).

Master Zend Framework with the € DocuMENTATION

A- &g Training Bundle! iew POF Caurse Cato ‘
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Education

Non

Programmers

Core Courses

PHP I
Foundations

PHP Ik
Higher Structures

{eg Perl Java, Cs+

Quick Start:
PHP for 00/Proc Programmers
|

00/Procedural

Programmers
VB Script, ASE, Python)

IBMi/0S
Programmers

PHPI: Foundations
for IBMi/OS Programmers

Building Security
into your PHP Applications

Test Prep:
PHP 5.3 Certification

Zend Framework Courses

Zend Framework: Zend Framework: Test Prep:
Fundamentals Advanced Concepts Zend Framework Certification

Product Courses

Zend Roadmap for PHP

SOAK
TIME

Insert->Header & Footer
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Education

« PHP 1: Foundations Training for IBM i Programmer

» Focus on fundamental PHP concepts _
» Covers basic HTML and JavaScript

» Class project that you can use in your shop, day 1!

» Interactive online delivery style

» Does not intrude heavily on busy shops
e Two hours a day, every other day, for three weeks
e No need for travel expense

e Must ensure proper environment for education (Conference room?)

30 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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Education

«How do | ensure success?
» Follow the roadmap
» Leverage “soak time” equitably
» Find time but don’t over estimate current workload
» Find REAL tasks to implement using PHP
» Skunkworks?

» Determine type of student, how did you learn RPG?

31 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.



Education

« Can RPG folks learn OO and Frameworks?
» Yes, absolutely! But...
» Must give time to absorb material

» What kind of student

e Visual thinker
e Book smart

e Osmosis

32 Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.




Education

- Osmosis or statistical learning (my experience)

» OK to start with Procedural PHP

» Grow into OO

» Zend Framework is component based

» Will learn OO/Frameworks by looking and doing
» Don’t underestimate the value of OPC!

LEARNING BY OSMOSIS

L ] L xtracellular spac
e’le o’ ®
. . o |® ®
o® 5 . . LY L ™Y
e . 0 ** o o ®
aQ ® e 9 L] L ]

s i

Intracellular space

OCCURS OVER TIME
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Education

* What about using a tool?

» Tools can be very powerful allies in tactical implementations
» Produce a lot of code in a short time
» Score big touchdowns with users quickly
» Leverage this type of resource carefully
- But...
» Generated code can be unmanageable
» Throw away and recreate vs. maintain creates risk!

» Still need to understand underlying code when users asks why?

Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. "
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Education

| need to use an IBM i, right?
» No, not exactly
» PHP is the SAME syntax regardless of platform
» What you learn on Linux/Windows can be leveraged on IBM i

e But...

» There are friends of the community out there...

Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.



Education

«iDevCloud.com

» Low cost access to IBM i resources for training purposes

» Shared or dedicated LPAR’s

» Zend Sponsorship delivers Zend Server to all environments!
» Various OS levels

» Expert system management

[Tungie

Survive= Adapt S Thrive

» Article at IT Jungle
e http://www.itjungle.com/fhs/fhs081010-story01.html

» Thank you Larry and Jim!

36 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘d
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Find an excuse to play with PHP

e Internal IT application

- Boss was always asking for IBM i system specific info

» System Values, mostly
« Create PHP script showing important info @ click of a mouse
e Other ideas:

» Helpdesk automation of green screen tasks
» Mundane processes

» RPG reports to the web

38 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.



System Values Code Part 1

1= <html> <head><title>Customer Insert<f#itle></head><body>

<h1>Main Computer Information</h1>
<?php
include("i5db2connectonly.php™);

/f$conn =i5_connect("localhost”, "PHPDEV", "phpdev1");

—
CQOWoOO~NOODOLE, WN

11 /Af (1$conn)

12 /ldie("<br>Connection failed. Error number =" .i5_errno() . "msg =" .i5_errormsg());

13

14 //Define table and start filling rows...

15 echo '<TABLE BORDER="10" BORDERCOLOR="red"><TBODY BGCOLOR="00FF00">',
16 echo '<TR><TD><B>Description</TD><TD><B>System Value</TD></TR>’;

17

18 print "<TR><TD>Model</TD><TD>" . i5_get_system_value("QMODEL") ."</TD></TR>";

19

20 print "<TR><TD>Serial</TD><TD>" . i5_get_system_value("QSRLNBR") . "</TD></TR>";

© All rights reserved. Zend Technologies, Inc. "
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System Value Code Part 2

34
35
36
37
38
39
40
A1
42
43
A4
45
46
A7
A8
49
50
51
52

print "<TR><TD>Minimum Password Length</TD><TD>" . i5_get_system_value("QPWDMINLEN") . "</TD></TR>",
print "<TR><TD>Maximum Password Length</TD><TD>" . i5_get_system_value("QPWDMAXLEN") . "</TD></TR>";

print "<TR><TD>Auto Config</TD><TD>",

|
if(i5_get_system_value("QAUTOCFG") == 1) {
echo "On";

}

else {
echo "Off";

}
print "</TD></TR>";

echo '<fable>';
i5_close($conn);
7>

© All rights reserved. Zend Technologies, Inc. "
zend



System Values Output

[ Customer Insert »

<« C ¢ http:ficuperl.zend.com 89/ mpavlak [COMMONSysYals, php P O~ F~

[ Mew Tah [ other bookmarks

Main Computer Information
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Wrap up
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Resources

 Recorded Webinars

» http://www.zend.com/en/resources/webinars/IBM i-0s

« Zend Server for IBM i main page, link to downloads

» http://www.zend.com/en/products/server/zend-server-ibm-i

« Zend Server manual:

» PDF: http://www.zend.com/topics/Zend-Server-5-for-IBMi-Reference-Manual.pdf

» Online: http://files.zend.com/help/Zend-Server-5/zend-
server.htm#installation guide.htm

Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.
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