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Zend PHP Conference
October 17-20, 2011 — Santa Clara, CA

Join us at ZendCon
The premier PHP conference!

October 17-19, 2011 — Santa Clara, CA

N | N
Conference Highlights Conference Topics
e Learn PHP best practices for architecture, design e Architecture & Design
and development e Expanding Horizons
e Technical sessions for all knowledge levels *IBMi

e Lifecycle Best Practices
e NoSQL / Alternative Stores / Search
e PHP Development

¢ In-depth tutorials for advanced learning
e PHP Certification courses and testing

* Exhibit hall showcasing the latest products e Server/Operations
e Networking opportunities with peers and luminaries e SQL
e Zend Framework
www.zendcon.com



Audience

* New to PHP
» New to Object Oriented Design

« Open to new ideas and methods
e This is not a DEEP DIVE

» Relax and enjoy the ride!

4 Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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Agenda

e Quick review of PHP basics
» The class and its object

-« Components of an object

» Properties

» Methods
o Other OO stuff
* | don’t know OO: Get Started NOW!

5 Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘d
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Roadmap to Expert PHP
- RPG Green Screen = PHP Expert

. Start somewhere! Here isn’t bad!
. Path

« Procedural PHP

. OO PHP

. Zend Framework (or another)

. PHP Certification

© All rights reserved. Zend Technologies, Inc.



Questions?

- Let’s keep it interactive!

» Follow us!
n » http://bit.ly/cjueZg (Zend Technologies or search for Zend)

» http://twitter.com/zend

© All rights reserved. Zend Technologies, Inc.
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Variables

« Rules
» Case senstive
» Begin with $
« SthislsMyVariable
« S__ AnotherVariable

o S thisis not a variable
» Implicit casting
» Can be re-typed (Dynamically Typed Language)
« Constant - Variable that doesn’t change
» Define(‘TEACHER’, “Mike Pavlak”);

| 9 l Modernizing legacy applications on i5 with PHP © All rights reserved. Zend Technologies, Inc. gﬁ



Variables and their types
« Scalar

» Integer
e -2,147,483,648 thru 2,147,483,647
e Supports decimal, octal and hex representation
» Floating-Point
e 1.7E-308 thru 1.7E+308
« 15 digits of decimal precision
» Strings
« Big. Really big. Too big to discuss!
» Boolean

« False is 0, 0.0, false keyword, empty string, object w/no values, null. All
others are true

« Object, array, null and resource

|
10
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Variables...(cont.)

e Scope
» Global - Available everywhere but inside function (sort of)
» Local - Available only in a function, destroyed at end

» Static - Available only in a function, but remains

« Arrays (three types)
» Enumerated
» Associative

» Multi-dimensional

I
11
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Functions

» Functions come from 1 of 3 places
« Built-in
. Part of base PHP
. Extensions
« Components of modules like image functions in GD
« User defined

« You will create these!
- You may have been using functions...
« db2_connect()
e print_r
. strtoupper

. Etc.

© All rights reserved. Zend Technologies, Inc.
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What do functions look like?

Function call has three major parts:

Function Name - Required
Parameters - Optional
Return Value - Always returned, default null

$

$conn = db2_connect(localhost’, $UserlD, $Pwd);
1

© All rights reserved. Zend Technologies, Inc. ”
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Scope

« Variables have scope, much like RPG ILE
- Function keeps its own set of variables
- Global keyword can change all that (RPG lll)

- Better to pass, globals can’t be trusted

» Static variables

- Persistence from call to call

© All rights reserved. Zend Technologies, Inc.



Parameters

Default

- Assign value in interface

Pass by value

- This is the default behavior

Pass by reference

- This is done with & before the variable in the interface.
Variable number

- func_get_args()

- func_num_args()

- func_get_arg(argument_#)

© All rights reserved. Zend Technologies, Inc.
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Jun-

Concepts

« Keywords
» class
» function
» static
« Concepts
» Class
» Instance
» Magic Methods
» Visibility

Name of this section

© All rights reserved. Zend Technologies, Inc.
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RELAX!!!

You may not be comfortable with the more modern structure
Don’t feel like you NEED to follow it

Take your time learning it. PHP lets you do this

) Name of this section © All rights reserved. Zend Technologies, Inc. r!‘
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Jun-

Bare minimum

- Keep library files out of the document root
« Always name your PHP files .php
- Keep data out of the document root
« Do not deploy with a phpinfo.php file
» Do a Google search for “inurl:phpinfo.php”
» Do not allow the web server to write to the document root
« Always validate your input.

» Do a Google search for “inurl:page=home.php”

Name of this section © All rights reserved. Zend Technologies, Inc.



Object Model

. Object is centered around data, not logic
- Think about your RPG programs
- You manipulate data.

. Very few programs that have no data access

. Object Definition:

. @ itnocal to

€acn OD]JecCt.

- Keep routines similar to data element together

© All rights reserved. Zend Technologies, Inc.



Where to get more on OOP?

o http://www.php.net/manual/en/language.oopb5.php

PHP: Classes and Objects (...

= C | 9¢ him: A php.net/manualienjanguage.cops.php

#PHP Manual

~Language Reference

o Basic syntax

o Types

Variables

Constants

Expressions

Operators

Contral Structures

Functions

Classes and Objects (FHP 4)

. Classes and Objects
{PHP 5}

MNamespaces

Exceptions

References Explained

Predefined Variables

Predefined Exceptions

Predefined Interfaces

. Context options and
parameters

search for

«Comparing objects

view this page in IE\ngarian j
Classes and Objects (PHP 5)

| Table of Contents

Introduction

The Basics

Autoloading Objects
Constructors and Destructors
Wisibility

Scope Resolution Sperator {32}

Static Keyword
Class Constants

Class Abstraction
Object Interfaces
Overloading
Cbject Iteration
Fatterns

Magic Methods
Final keyword
Object cloning

RN function list

> O £-

3 other bookmatks

Introductions

Last updated: Fri, 10 Jul 2009

© All rights reserved. Zend Technologies, Inc.
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Class

. Think of a class as Source Code for object

. Defines object via properties and methods

1 <?php

2
EESMERER)) | - class customer  {CTREENEREN
4 {

p OO ~N O On

© All rights reserved. Zend Technologies, Inc.



Hello World Class

1 <?php
26 **

* This class will display whatever is passed in to it...

3

4 *

S |/

6-fclass Hello {

7 | public $message;
84 public function display () {
9

10

11

12

print_r($this->message);

}

13 $newMessage = new Hello();

14 $newMessage->message = "Hello World";
15

16 $newMessage->display();

17

18 7>

© All rights reserved. Zend Technologies, Inc.
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Hello Class

Output looks strangely familiar!

[ http:ffcuperl.zend.com:g9,., »

€ C ¢ http:ficuperlzend.com:59/mpaviak/php 102/php 102wSEx 1.php P G K-
[ Mew Tab (] other bookmarks

Hello World

© All rights reserved. Zend Technologies, Inc. u
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Question

Why would you not just use functions that are already in
global scope?

Problem

» There is no auto-loading mechanism for procedural code

» This means that ALL functions need to be loaded for EACH
request

» Structure is defined 100% by naming convention
Answer

» Using classes to structure functionality means

1. Only required functionality is compiled

2. IFS access is minimized (this is good!)

Name of this section © All rights reserved. Zend Technologies, Inc. ‘
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Class Properties

. Properties are also referred to as data

. Data representative of the class

. In our case, attributes about the customer

. Name
« Number

. Address

- class customer
{
private $name;
private $address;
private $city;
private $state;
private $zipCode

OCO~NOOOLA W

© All rights reserved. Zend Technologies, Inc.



Class Methods

- Methods are essentially functions in a class

- Provide database and some business logic

. In this example the method is display()

class Hello {
public $message;
public function display () {
print_r($this->message);
}
}

hethod

© All rights reserved. Zend Technologies, Inc.



Notes on objects

* Create Object:

- SmyObject = new Customer;

* Destroy Object
- Unset SmyObject;

© All rights reserved. Zend Technologies, Inc.
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agic methods

- Methods are functions
. Magic methods are like special reserved functions in PHP
« Must begin with double underscore _

« More info?
http://www.php.net/manual/en/language.oop5.magic.php

> O F~

(] other bockmarks

R0 Function list

=PHPF Manual «Patterns Final Keyword»

~Language Reference view this page in [Bygarian - Last updated: Fri, 10 Jul 2009

Classes and Objects ¢ Methods
(PHP 5)
o Introduction The function names __construct,  destruct,  call, liStatic, __get, _ set, isset, _ unset, _ sieep,  wakeup,

tostring, __invoke, _ set state and __clone are magical in PHP classes. You cannot have functions with these names in any

a The B.
© Basies of your classes unless you want the magic functionality associated with them

s Autolaading Objects

o Constructars and
Destructors

= yisibility

. Scope Resolution Operator

Caution

i FHP reserves all function names starting with __ as magical. It is recommended that you do not use function
Static Keyword

° al names with __ in PHP unless you want some documented magic functionality.

® Class Constants

8 Class Abstraction

8 Object Interfaces

8 Overlpading

8 Object Iteration ___sleep and__wakeup

a Patterns

= Magic Methods serialize() checks if your class has a function with the magic name __sleep. If so, that function is executed prior to any

= Final Keyward serialization. It can clean up the object and is supposed to return an array with the names of all variables of that object that
o Object cloning should be serialized. If the method doesn't return anything then s is serialized and E_MOTICE is issued

= Comparing objects

= Reflection The intended use of __sleep is to commit pending data or perform similar cleanup tasks. Also, the function is useful if you have
= Type Hinting very large objects which do not need to be saved completely.

® Late Static Bindings

= Objects and references Conversely, unseriglize() checks for the presence of a function with the magic name __wakeup. If present, this function can

reconstruct any resources that the object may have

The intended 1ica nf__wabein ic to rasctahlich anu datshacs cannsctinne that mau haus haan lnet diring cerializatinn and =

© All rights reserved. Zend Technologies, Inc.
zend
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Magic Methods

« Methods in objects that are called at special times

- They always start with double underscore (__)

> construct () *

> destruct ()

» call()
» __get ()

»  set ()

» sleep()

»  wakeup ()

» toString() *
I

J Name of this section © All rights reserved. Zend Technologies, Inc.
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Constructor

_ _Construct()

. Think of it as *INZSR

. Executes code when object is instantiated

public function ___construct() {
print_r("Object created<BR><BR>");
}

© All rights reserved. Zend Technologies, Inc.



Destructor

_ _Destruct()
« Think of it as *INLR

. Executes code when object is destroyed

public function __destruct() {
print_r("<BR><BR>0Object destroyed<BR><BR>");

}
}

© All rights reserved. Zend Technologies, Inc.



Hello Class with Magic Methods

class Hello {
public $message;
public function display () {
print_r($this->message);

}

public function __construct() {
print_r("<h2>0bject created</h2>");

}

print_r("<h2>0Object destroyed</h2>");
}
}

$newMessage = new Hello();
$newMessage->message = "<h1>Hello World</h1>";

$newMessage->display();

unset (fnewMessage);

public function __destruct() {

© All rights reserved. Zend Technologies, Inc.
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Visibility
. Public

« Access to both inside and outside
. Private

« Access to only inside

. Protected

- Access only within the object itself, or other objects that
extend the class.

© All rights reserved. Zend Technologies, Inc. "d
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Visibility

 Allows you to limit what parts of a class are available to
other parts of your application

| bevicion | Exenanaclos |l
% 4 @
2 @
%

Name of this section © All rights reserved. Zend Technologies, Inc.
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Visibility

class Hello {
public $message;

private $privateMessage="this is the private message”;

public function display () {
print_r($this->message);
echo $this->privateMessage;

}

public function __construct() { |

public function __destruct() {
}

$newMessage = new Hello();
$newMessage->message = "<h1>Hello World</h1>";

$newMessage->display();

if (isset($newMessage->privateMessage)) {
print_r( "$newMessage->privateMessage <br>");

}

else { echo "<br>privateMessage not found"; }

unset (JnewMessage);

D htkp:ficuperl.zend.con:&9,,,

L C % htpficuperlzenc » O S~
[ other bookmarks

[ Mew Tah

Object created

Hello World

this 15 the private message
privatellessage not found

Object destroved

© All rights reserved. Zend Technologies, Inc.
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You don’t need to know OO to use it

. Using objects does not require OO0 knowledge
. Easy to weave into Procedural PHP applications

. http://www.phpclasses.org/

PHP welcome ko the PHP Classe. ..

L C O www phpclasses.org

Ocontem

} PHR.. s«

. Welcome to the PHP Classes Repository )
w Search — > " All class groups 50 Latest entries 3§ Top 10 charts ¢ Blog & Forums  “? Help FAQ

- hil
Recormend this page to a friend! B Lke (1K A Tweot | 182 ﬂstumblelt! éﬂookmaﬂ(indel.icio.us
a

% I%?:liﬁHulzhghs E BOOST SQL SERVER PERFORMANCE IN 30 MINUTES ‘E 100% AUTOMATED OPTIMIZATION OF S5QL SERVER E Test your skills
BHP :' 3 E at the forums!!!
p— 2 = -] > 5
professionals o d = = 2
directory G FHEE THIAL < FHEE THIﬁL <)

Ads by Google FHF Code Tutorial FHF Download

FHF Database Seoripts FHP Applications

$Q.£"l  PHP Class Scripts
.!F' Find useful PHF components

¢ PHP Tutorials
Technical articles about FHF and related matters

| PHP Book Reviews "
Yy hd zend



http://www.phpclasses.org/

ﬁ email address validation - P...

= C 9% htp:/fwww phpclasses. org/search. htmi?words =emai+ address +validationfx =98y =9Rgo_search=1 P O F~

email address validation -

: Search this site

Search for: |emai|address validatio.  Go |

Sections: ¥ Packages ™V Reviews ™ Blogs M videos ™ Discussions

searchforums: © Mo ™ In selected sections & Only in forums

Permalink

IRREE g Packages (52) @Reviewsm dalngsmz = SPackauemrums (46 d &Ellng farums (43
m 11-20 | 21-30 | 21-40 || 41-50 | Mext=

View All Online Classes
University of Phoeni<®Bl Learn About Accredited Programs . Search Mowil

Phoenix.edu

ads by Google

1. Validations 100%

Validations validations Validate text values according several rules This is a simple class implements several rules tovalidate text values on the server side,
eventually submitted by the user in Web forms. Currently it implements the following validation rules: - E-mail address - Signed integer ...

2. Generate Javascript Validation TO%

Generate Javascript Validation generatejsvalidation Generate Javascript code forvalidation Web forms  Thig class can be used to generate Javascript code for
validating VWeh forms. lttakes as parameter a list of form fields to he validated that details the field names, types ofvalidations to be ...

3. Combo Validation 53%

Combo Validation combovalidation Validates YWeh farms on browser and server side Custorm Custom Custom display - Custam Div Custarmn display |, farm

PR F R P VT LT F PR TN LT ENR e F VTRV B = R F R PR N SO 0 I S £ P PR R PR | NP PRV RR TR PR M PR W T I | BOW TRy Yo 1
——

41 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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B Email validation (filker) - PH...

=

C | 9% htip:/fwww phpclasses.org/package/s 148-PHP-Validate-a-ist-of-e-mal-addresses-from-a-file. him

y

Ads by Google  Ermail Address Validate Validate PDOF Form validation Yalidate Marme

Miarmi Painters
Find Miami FPainting Contractors & Painters for Home or Business.

yellowpages .com
Chitika | Select

Classes of Mahmoud Farag > BEUETRTEILETM > | Download | > 85“”0'”0"“'“ > dB—Jlo‘ > XML R\ Latestchanges

Your custom journey begins here.

Call R. Crusoe & Son at -490-8049,

Or VISit U8 3t WWW.ICTUSOE.COMm.

hikEps f P, phpclasses . orgfsearchtagyfilker /by fpackageftag)Filker!

Name: Email Validation Support forum
Base name: inporter-mail
Description: Validate a list of e-mail addresses from a file

Related top rated classes: filter

Version: -
Required PHP version: 5.0

License: GpU General Public License (GPL)

Alltime users: 272 users
All time rank: 4742
Week users: 269 users

Week rank: 4

Author | ) Groups || petailed description

J Userratinds — applications | = Elles

42
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ﬁ Email ¥alidation - PHP Classes

=

C % htip:/iphpclasses.elib.com/package/s 148-PHP-validate-a-ist-of-e-mai-addresses-from-a-file hitml

Buthor

Mame: Mahmoud Farag <2-mail contact>

Fublished packages

> E\ Browse this authars classes

Courtry: hEQIF‘_t EHP jobs in Egvpt

Hame page: 77

Groups
_\ Email Emzil =ending and receiving Wiew top rated classes
%\ BPHRPS Classes using PHF § specific festures  Miew top rated classes
“alidstion “alidation algarithms Wiew top rated classes

Detailed description

This class can be used to validate a list of &-mail addresses from a file.
It can import a list of e-mail addresses from a given text file.
The class can validate the e-mail addresses discarding those with inwalid syntax ar are duplicated.

The filtered list of e-mail addresses iz returned as an array.

Applications that use this class

Mo application links weere specified for this class.

‘&,;, If ywou knove an application of this package, send a3 message to the authorto add a link here.

Files
File Role Description
®, emails.tat [rata Emails for example
#®, zmample.php Example example
#®, walidate.class.php Class walidate multi emails

" Choose a Child

World Vision q

www.worldvision.org

43

Insert->Header & Footer
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Copy files to IFS

& emailvalidate =10l =l
Eile Edit ‘ew Favorites Tools Help | 1','
@ Back = | | = LE ./"' ) Search /e Folders ‘ v
Address IE} Ch\Documents and Settingsimike, piMy DocumentshQld laptoptDownloads) Softwaret Open SourcelphpClassesOrglemailalidate j Go
File and Folder Tasks &
:& Move the selected items
Copy the selected items
Publish the selected items
to the web
5] E-mail the selected items -0l x|
¥ Delete the selected items Eie Edt \iew Help
ED|$E|X|@Q 1 minutes ald
Other Places Fy | Environment: My Connections | 192.168,15.203: ValEmal Include: *.*
w1 QFPNWSSTG - i
) phpClassesorg H-1 0 _I Marne | SIZE.'I Tyvpe | Changed |
emails. bk 1IKE  Text Document 4292010 350 PM
My Dacuments example.php 1KE  PHP file 4/79/2010 3:50 PM
52 My Computer validate. dass.php 3KE PHF file 4{7a/2010 3:51 PM
\:g My Metwork Places
-2 wirtual_media J
Details ¥ E|[:| e
m ajsp
1-[[] apachedft
[m_"l iveadft
EI[m_"l zendswr
o - conf
E||1"| htdocs
Guestbook
. 03 Guesthok =14l +
[ [1 - 3 0f 3 objects | .
3 objects selected |2.82 KE | ﬂ Iy Computer ,}‘_‘l
44 Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. "
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Test the example...

#%PHP - RemoteSystemsTempFiles,/192.168.15.203 /'www /zendsvyr /htdocs/mpavlak /¥alEmail 'example.php - 2end Studio - |I:I|i|

File Edit Source Refactor Mavigate Search Project Rum Window  Help

It~ @ F || |- |3-0-0-4- 86 le® - 4@ 5 | &l pHp
IHZRE RS CRCRE-HRY N SN

— ™ —
@ MikeRestType. php (@ MikeReskCity, php ﬂa MikeRestList, php ( hiosts (@ Samplelava.php emails, bxk 1}}2 =&
= = =
1 <?php 5 (1
H Z |//include php core class o=
'Eg 3 dinelude('walidate.class.php'): @
ﬁﬁ 4
5 fimport = new arrayManager ['emails.txt'):
- 6 $true_emails_arra‘_:,:r = $imp0rt—>execute_class [
= 7
A g
9 |// ftrue_emails array is ready to add to datsbhase
10
11 echo '<prex>':
12 print r i$true_emails_arragr] H
13 echo '</prex':
14
15 | 2>
w
&l *
J nj | Wiritable Smark Insert | 15 1 J J'f' J
[RERERZE = R
45 | |nsert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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Source Data-> Array Output

=01 x|

File Edit Format Yew Help

mahmoud@yahoo. com
Farag@ﬁmai1.cum
ahmed@hotmat
Zipo@man. com
farag8ymail. com Evalidate.class.php-Email Vo o® D hkkpeff192,168,15.203: 10, ..
mahmuud.uuﬁ@gmai1.cum
mahmoud@yahoo. com €« C s htp://192.168.15.203; 10088 /mpaviak fvalemalfexarmple. php > O~ F-

ahmed_noo7@hotmail. com
ahmed@msn. com

mabmoud. cop@gmail. com Lrray

ahmed@msn. com i

medyahoo. com 01 = mahmouddvah

dodo@kos. asd (o] e @?é me . Eo
down@hotmai. sss [1] =» farag@ymail.com
down@hotmai. sss [2] => =zipolman.com
down@hotmai.sss [3] = mahmoud.oopfomail.com
magfy [4] = ahmed noo7Bhotmail.com
ax0a . Bl == ah.medﬁmsn (du) ]

aljkshd askljdh asd [ -
boss@gmailre.mss [6] => welyahoo.com

[7] =» dodofikos.asd
[3] =» downfhotmai.sss
[2] => hossigmailre.mss

|E] validate.class.php W |E] example.php T uSth all downloads,., X

Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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But | only want to check one email...

*3PHP - RemotesystemsTempFiles; 192.168.15.203 /'www zendsyr /htdocs /mpavlak/¥alEmail/vahdate.class:ph - |EI|5|
File Edit Source Refactor Mawigate Search Project Bum indow  Help
= £ = o
Ii-BelFE |0 @ - 3-0--%- 148 |- | &) Pre
| 1@ |& -3l -0~ 0| &-0]
— @ MikeRestType.php (@ Samplelava.php (@ example.php =
= =
28 fnum row = B count (array_filter($array)): A||:| B
B if ($mum_row == 04 o=
Tg 30 return false; S/ Empty Lrray El
JE 31 relsed
3z return true; S/ Not Empty Lrray
- 33 '
g 54 }
B | =5
3G f/Email Regular Expression checking email syntex
37 //private function check email ($mail){
public function check ew&il ($mail)d
fpatter = "/*[a-zl-Z0-89. -J+0@[a-zA-EZ0-9-.1+.[a-gL-Z. 1{Z,61%/";
if (preg watchiipatter, fmail)){
return true;
}else{l o
return false;
i
¥
FSiConverting file emails into array
private function conv_to_array 0(]{
§file = file(Sthis-»txt_f£file path):
fthis-remaillist = str_replace {"\r\n", """, ifile);
return ithis-remaillistc: -
_*I_I
J <> PHP | Wirikable | Smart: Insert | 42115 J J'f'
| | B &8 830 %H
47 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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Code and output...

*3PHP - RemoteSystemsTempFiles;192.168.15.203 /'www zendsyr /htdocs/mpaxlak, ¥alEmail - | jm] | 5'

Elle Edit Source FRefackor Mavigake Search Project RBun  Window Help

Ici-He| B0 % | k- |- 0-2-%-|8& | &l prp
lo®2-0[4]@ |8 -Gl-0- 0| 4=

- @ MikeRestTvpe.php I,@ Samplelava.php

echo '<brex<br:';

Jee@joesbeet com -- Email Good

1 |<2php Evalldate.class.php-... * Dhttp:,l',l'l'?lE.lE-B.lS.E...
z2 /fincluds php core class

3 |include (' validate.class.php'): €« C ¥ htip://192.168.15.203: 10085/mpa » | O~ M~
4

5 Simport = new arrayvManager (' emails.txt'); S
6 §true emails array = §import-rexecute class|(); Lrray

7 {

8 [0] == malmoudlyahoo.com

9 |/4 $true emails array iz ready to add to datab) _ .

; - - [1] == fsllrag@mnall.cnm

1 echo '<pres': [2] =» Eipoflman.com

2 print_riftrue_emails_array): [3] => mahmoud.ooplomail.com

3 echo '</prex': [4] =» ahmed noo7fhotmail.com

4 ) ) ) [5] =» ahmedimsn.com

5 $ewail = 'joeljoesheef.com':

& §result = §import->check email (femail); [6] => me@yahnn.cnm

7 if (3result === TRUE) [7] =» dodollkos.asd

g echo "femail -- Email Good"; [8] =» downfhotmai.sss

2 else = :

] echo "§email -- Email Bad"™; [=] ” bDSS@gmallrE.mSS

1

z

3

4

5

3

7

=]

=]

u]

femail = 'joeljoeshee’;
fresult = §import->check _email (femail);
if [§result === TRUE) Joe@joesbes -- Emal Bad
echa "§email -- Email Good™;
else
echo "$email -- Email Bad™; |E] validate. class.php i E3 show all downloads... X
;I jme | 1
‘ ‘Wiritable | Smatt Inserk | 20 32J J'i'
| | 2B & 00
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Books!

BRUCE PERENS" OPEN SOURCE SERIES

PR
e e PHP 5

IN PRACTICE

* Gutmans - PHP 5 Power Programming
* White - PHP 5 in Practice
 Schroeder/Olen - The IBM i

© All rights reserved. Zend Technologies, Inc.

JUeff Olen and Kevin Schroeder

Z
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00/Procedural

Programmers
{eg Perl Java, Cs+ VB Script. ASP, Python)

Quick Start:
PHP for 00/Proc Programmers

Building Security
into your PHP Applications

Non
Programmers

IBMi/0S

Programmers

Core Courses

PHPI: Foundations
for IBMi/0S Programmers

PHP I
Foundations

PHP Ii:
Higher Structures

Test Prep:
PHP 5.3 Certification

Zend Framework Courses
Zend Framework: Zend Framework: Test Prep:
Fundamentals Advanced Concepts Zend Framework Certification
Product Courses

Build on OOP!

PHP I
Higher Structures!

Call your account manager
or go to the Zend website:
http://shop.zend.com/en

/php-training.html

Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.
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Resources

 Recorded Webinars

» http://www.zend.com/en/resources/webinars/i5-0s

« Zend Server for IBM i main page, link to downloads

» http://www.zend.com/en/products/server/zend-server-ibm-i

« Zend Server manual:

» PDF: http://www.zend.com/topics/Zend-Server-5-for-IBMi-Reference-Manual.pdf

» Online: http://files.zend.com/help/Zend-Server-5/zend-
server.htm#installation guide.htm

Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.
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zendcon

php2on

Zend PHP Conference
October 17-20, 2011 — Santa Clara, CA

Join us at ZendCon
The premier PHP conference!

October 17-19, 2011 — Santa Clara, CA

N | N
Conference Highlights Conference Topics
e Learn PHP best practices for architecture, design e Architecture & Design
and development e Expanding Horizons
e Technical sessions for all knowledge levels *IBMi

e Lifecycle Best Practices
e NoSQL / Alternative Stores / Search
e PHP Development

¢ In-depth tutorials for advanced learning
e PHP Certification courses and testing

* Exhibit hall showcasing the latest products e Server/Operations
e Networking opportunities with peers and luminaries e SQL
e Zend Framework
www.zendcon.com



Q&A
www.zend.com

mike.p@zend.com

Please fill out your
Session Evaluation!
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