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Questions?

 |f you have a question you can

» Type in the Q&A panel

e Follow us!
n » hitp://bit.ly/cjueZg (Zend Technologies or search for Zend)

- » http://twitter.com/zend
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Resources

e Recorded Webinars

» http://www.zend.com/Zen/resources/webinars/i5-0s

e Zend Server for IBM 1 main page, link to downloads

» http://www.zend.com/en/products/server/zend-server-ibm-i

e Zend Server manual:

» PDF: http://www.zend.com/topics/Zend-Server-5-for-IBMi-Reference-Manual. pdf

» Online: http://files.zend.com/help/Zend-Server-5/zend-
server.htm#installation guide.htm
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COMMON 2010 - Fall Conference and Expo

« Six sessions on PHP from Zenders
» Mike Pavlak

e More sessions by community members
» Alan Seiden, Brian may

< Visit us Iin the Zend Booth

e
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84 7end/PHP Conference

Join us at ZendCon
The premier PHP conference!

November 1-4, 2010 - San Jose, California
| | |

Conference Highlights Conference Topics

e Learn PHP best practices for architecture, design e Architecture & Design
and development e Expanding Horizons

* Technical sessions for all knowledge levels * IBMi

e Lifecycle Best Practices
e NoSQL / Alternative Stores / Search

® PHP Development
* Exhibit hall showcasing the latest products e Server/Operations

e In-depth tutorials for advanced learning
® PHP Certification courses and testing

* Networking opportunities with peers and luminaries e SQL
e Zend Framework

Wwww.zendcon.com



Application Development Update from IBM

e Alison Butterill -
Application Development
Offering Manager, Power
Systems Software.
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IBM Relationship FAQ’s

e What do we get?
» Zend Server CE
» Zend Studio

» 1 year Silver Level Support (email/web 72 hour response)

« What happens after 1 year?
» Products will still run (Perpetual license)
» Limited updates to product or PHP

» Forum support only
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IBM Relationship FAQ’s

e What do | do when support runs out?
» Roll the dice

» Zend account representative can discuss support options

| downloaded Core and it’s been a year. Can | download
Server and get support for another year?

» Yes! You can download Zend Server!

» But once the support runs out on Core, there is no additioanal for
Server...

» Forum support is always available

10 ' Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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A Closer Look at Zend Studio
e Built on Eclipse / PDT

» #1 ranked in InfoWorld PHPIDE review
» #1 project at Eclipse.org

e Supports Agile development

» Refactoring, PHPUnit, code coverage, profiling

= Slashes root cause analysis time

» Zend Server Monitoring captures problem in
production

» Developers step through problems to quickly
pinpoint root cause

e Fully integrated with Zend Server

e Fully integrated with Zend Framework

© All rights reserved. Zend Technologies, Inc. "
zend



What Is Zend Server?

A Complete, well-tested and supported PHP 5
stack - 70+extensions, DB connectivity,
Troubleshooting, web based admin, and alot
more

< Rapid root cause analysis with whole application
monitoring (integrated with Zend Studio and an
alerting system)

e Code Tracing Detailed Diagnostics of problems
captured in realtime cuts troubleshooting times in
half.

= Multi-level performance enhancement capabilities
Increases systems from 2 to 100 times faster

= Job Queue, Java Bridge, Download server

e Phone support, Easy Install, Software updates and
security patches

12 What is Zend Server © All rights reserved. Zend Technologies, Inc. "
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Zend Server

Zend Server

Performance Application Availability & Reliability
Optimization Management Scalability

Acceleration Monitoring Job Queue Updates

Optimization Diagnostics Java Bridge Hot Fixes

Caching Configuration Downloads Support

Zend Framework
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Zend Server for IBM |

 Next generation of PHP stack for IBM i
e Best of both Zend Core and Zend Platform
= Single Licensed Program Installation

e Two products

» Zend Server for IBM i Community Edition
e Available at no charge per IBM partnership
» Zend Server for IBM i
e Subscription available from Zend
e High value extra features

e Higher Support SLAS

14 ' Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.
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Why a new generation?

- Based on feedback of key areas for Improvement
e Improved basic PHP Performance

» 30% to 600% depending on the application
e New capabilities

» Code Tracing - Faster problem resolution

» Job Queue - Performance and scalability

» Page Caching - Performance and Scalability
» Support for PHP 5.3

e Easier installation, administration & maintenance

15 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.



What about the old products?

e Zend Core iIs still available on the Zend Website for those
stuck on V5R3.

e Core and Platform have started the ““end-of-life”” process
e Customer are encouraged to move to Zend Server for IBM |

= Zend will continue to support Core and Platform through
the ““‘end-of-life”” process.

16 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. "



Zend Server for IBM i

www.zend.com

Explore free stuff in the Zend Products for IBM |




Sample Applications

e Customers have asked for examples
e Data inquiry

e Hello World

e Program call

- LDAP

e We heard you loud and clear!

« Samples use real data in DB2 & program in library ZENDSVR
» SP_CUST Table
» COMMONPGM RPGLE Program

e All samples work, right out of the box!

18 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.



Sample Applications

. Zend Server

€ > C M % htpy/192.168.15204: 10088/ ZendServer index/Index # 1283921158715 » O~ F-
[ Mew Tab . Zend Server Demo [T Other bookmarks

Welcome
Welcome to Zend Server for IBM i

8 Ways to Get Started with PHP on IBM i: PHP Open Source
Applications

1. Zend Server for B i user interface lets you manage your Zend Server and

FHF configuration Zend cust < and,

. PHP Toolkit 4P| enables vou to call RPGIGOBOL applications, systert running these PHP a Frodrarnmers o i

ohjects and data queues PHP
. Zend Mavigator Demo shows PHP Toolkit AP| access to active jobs, spooled Maritis/400 (B
files, user profiles, system values and more 8. Additional PHP Dermo Scripts
. Zend Studio for Eclipse helps you build your first PHP application
. 250 (AP Bridoe Demos demaonstrate how PHP can Web-enable 5250 tedistiiki (el
applications Joomlal {ShS)
. Zend Framework gives you a head start with secure, reliable, Zen Cart (Online Store)
Wieh 2.0 applications and Weh serices phpBB (Bualletin board)
. Foundations for IBM | Programmers and Guic . PHP for EF G
Frogrammers anline training courses ou started with the basics of PHP
. Additional PHP Dermo Scripts

HNote:

Zend does not offer commerical or other support for any of

thesze open source applications.

Enhance your PHP Learn how to start with Zend Server and PHP

Build ¥web Applications and Yeh senvices
using Zend Studio far Eclipse.
Learn about iS50S5 specific features.

™ Do not display this on nest login

19 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.




Sample Applications

. Zend Server

€« cC N K hito: /192, 168, 15, 204 10088,/ ZendServer Index,/Index # 1283921215445 » O~ S~

D Mew Tab - Zend Server Demo [T Other bookmarks

ol Monitor Rule Management ‘\ Server Setup stration

Dashboard Events Johs Cueue Statistics Code Tracing Server Info FHF Infa Logs Applications

Subfile Extended Demo

thon far (05

The Extended Subfile Demo demaonstrates how you can use the 5250 Bridge AP o recreate IBM i resources in aweb based environment without using the 5250 emulation
client look and feel. Like the Subfile Demo, this provides a way to extend your IBM | resources to the weh and provides a more user friendly application, as well as
dermonstrating how you can improve the layout using HTML and AJAX The demo itselfis based on a sample application with limited functionality. The sample application can
be viewed in a green screen by logaing into 1B i using yvour favorite Emulation and running the fallowing commands in order to view the ariginal format ofthe demo
application: ADDLIBLE ZEMDEVRE and CALL ZMI001R.

This demo application was written in PHP using the Zend 5250 Bridge Chject Oriented API using functions to organize the code and HTWL for the display. The source code for
this application can be found in fJustlocalizendswia2580fdemosrsubfileExtended. The main file is called index.php.

Zend Navigator Demo Application

The Zend Mavigator Demao Application dermonstrates the usage of the PHP toolkit for IBM i functions. The source code for this application can be found in
Jfusrilocalizendsvifapaches2ihtdocsl Zend_Mavigator_Demo. The main file is called login.php.

The derno application has the following options:

= Logon - This option allows you to logon to IBM i with a valid Systern i user profile.

= Active Jobs - This option allows you ta view all active jobs. You can use the "Load Subsystem® filter to viewy jobs in selected subsystems. Clicking on a job line will
dizplay same job details and job log.
Spoaled Files - This aption allows vou to view current user spoaled files. You can use the 'Load User user filter to display other users' spoaled files. Clicking in a
spooled file line will display the spooled file content. Some spooled file details and spooled file options such as DELETE, HOLD/RELEASE or display spooled file
content, will be displayed in FDF format.
System Value - This option displays a full list of all IBM i systerm values.
User Profiles - This option allows you to view all user profiles aon your server. Clicking an a user profile line will display some user details and user status options, and
wiill allowe wou to enable or disable selected user profile statuses.
Database files - This option allows you to view all database files on your server. Selecting a library fram the drop-down list and clicking a file will display all data in the
file. Click the 'File Description' buttan in the file display to see mare information on the file.

Additional PHF Demo Scripts

The additional PHF demo scripts will help 1B | developers get started with PHP

O Restart PHP vd

Tand

20 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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Sample Applications

. Zend Server = D PHF Dema Scripks ®
C M ¥ htp://192.188.15.204; 10088,/Samples/ P 0O~ K~
[ Mew Tab . Zend Server Demo [T other bookmarks

PHP Demo Scripts

The fallowing dermo PHP scripts will help IBM i developers get started with PHP.
Clicking on the script narme will run the code and clicking on the dsiplay code will display the PHP code

The scripts location is Awnsizendsvrihtdocs/Samples.

Hello Wiorld Display Code

-

SOL Access Display Code

L]

-

SOl Access using fend Framework DB2 adapter Display Code

SQL Access to MYSOL database Display Code

L]

Frogram Call Display Code

-

LOAR connection Display Code

L]

21 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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Sample Applications

e First entry shows application execution

e Second entry displays code

« Hello World Display Code

e S0 Access Display Code

« S0 ACCcess Using Zend Framework DBZ adapter Display Code

« S0 Access to MYSOIL database Display Code

« Program Call Display Code

o | DAP connection Display Code

22 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
zend



Sample Applications

.Zend Server D httpe /192,168, 15.204:10,,, =
L C | A | % http:/f192.168.15.204; 10088/5amples/SQL_access/DRZ
[ Mew Tab . Zend Server Demo
Executing SQL statement: SELECT * FROM ZENDSVR.SP_CUS']
CUST _ID = 1220 FOR FETCH ONLY
CUST_ID|COMPANY|FIRSTNAME|LASTNAME | CIVIL(|ADDE
Lo 4-076
1221 Eﬂgm 2“' ¢ lLova Norman 2 Sugail
¢ pp H“'y
1231 Unisco George ‘Weathers 1 Eg Bq
. » . 1t . i 1 Nept|
1351 Sight Diver |[Phyllis Spooner 1 Lane
Cayman
- Divers . PO Ba
1354 World Joe Bailey 1 41
Unlimited
1356 PAWY Chrig Thomas 1 Third
Diving Frvder
Centre Y
Blue JTack 23-738
1380 Aqua Ernest Barratt 1 Paddit
Center Lane
e
|

23 | Insert->Header & Footer

[l z=rd server [ http:/f192,168.15.204:10,.,  »

€« C | A | % http://192.168.15.204: 10088/5amples/S0L_access/Disp. » | [~ o~

[ Mew Tab . Zend Server Demo [ other bookmarks

-

<html>

<head>

<titlex</title’

<meta http-equiv="Content-—

Type"™ content="text/html; charset=i=zc-8859-1">

</head>
<hody>
<7php
Sconn reseurce = dbZ connect ("FLOCAL", "', "";:
if (lSconn resource)] |
echo "Connection failed. SQL Err:™;
echo dbZ conn_error();
acho "<br:":
echo dbZ conn_errormsg() ;
exlt {);
1
sche "Executing 8QL statement: SELECT * FROM ZENDEVR. 3P CUST

/* Construct the 50L =tatement */
Ssql = "SELECT * FROM ZENDSVER. 5P CUST WHERE CUST_ID > ? FOR FI

/* Prepare, bind and execute the DBZ 3QL statement */
Setmt= dbZ prepare (Sconn resource, Ssgl);
Slowser_limit = 1220; //from the CUST_ID wvalus

$fldz = dbZ2 num fields (Sztmt):

it (Sfld=s > 0 3

—_—
© All rights reserved. Zend Technologies, Inc.
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Zend Studio Templates

e Program call has a lot of steps
e Wouldn’t it be nice to reduce the number of steps?
e Fill in the blanks?

e Check out templates in Zend Studio!

25 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.



Zend Studio Templates

[] FendCustList1Funck, php ([] BasicClass.php

=

< ?php

i5np
E iSProgram - Call iS5 program i
= iSProgramService - Create a Web service For i5j0| This template allows to call any

Conects to 15 server
Opens a prograt or Service pro
Calls the programm and optiona

W o =1 oo o L

-

Free prograun resource handle
Closesz connection to iS5 serve:

m v Mo

1 | | sl // Set connection parameters:
Press 'Ctl+Space’ to show| /¥ If you want to use additional

26 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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Zend Studio Templates

L R e T Wy Y =YL 2 B S

LA o o R R el T T o R o
Eo B Ty Y =" Y LY 0 S Y e R W3 Y <N ST LR e Y

28
Z9
30
Sl
3z
33
34
35
3@

<?php

l.fﬁ

This template allows to call any i5/03 program with parameters

Opens & prograsn or Service procedure and prepares it to be run
Calls the prograwr and optionally accepts results

=

A4 If wou want to use additional connection options, remwove comments in the array hlock

ji0h name

'8l naming',

/4 Define machine name by default
A/ To uze dotted (.]) or =zlashed (/) notation in 30L requeats

'decimal point', A4 To use dot or comma a3 decimal sSeparator

‘code_page _file', // To use a specific code page

'alias',

1. Conects to 15 sServer

2.

3.

4. Free program resource handl
5. Clozes connection to i5 server */
/4 Set connection paramseters:
$connection_parameters = arrayl
A¢ 15 OPTIONS JOBNAME =
A 15 OPTIONZ SOLNAMING =
A 15 _OPTIONS DECIMALPOINT =>x
Af 15 _OPTIONS CODEPAGEFILE =
A IS _OPTICNS ALILS =
A¢ IS _OPTIONS INITLIEL =

1z

foonn = iS5 eonnecti'127.0.0.1

if (is_resnurce(Sconn]] {

/% Prepare File for execution

PHP-format program descrip

"init libl'

;, 'user name',

tLion

/¢ Enabhles naming & connection
S Zpecifies initial library

'password' /*, Sconnection parameters ) ;

Thiz should he provided if the program is not described on server

MName - name of the field

Type - type of the field,
IS _TYPE CHAR
IS _T¥PE _INT

can be:

27 | Insert->Header & Footer
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Zend Studio Templates

= To see more

» Windows -

» Preferences -

» PHP -

» Editor -

» Templates
 Like

» Spooled file

» Data queue

» Object list

» Many more!

=] .9
|ty|:ue filter bext Templates T ¥
- General -
" Data Management — Create, edit or remove templates:
__ Dwnamic Languages ame Conkext Description Auko Ins, = LI
- Field Assist | = :
.. Help = Edl—tl
- InstaliUpdate
e Z | ferere |
- fppearance -
.. Corle Coverage = = '-'FI Restare Femayved
- Code Gallery Revert bo Default |
- Code Refackar =
[~ Code Skyle _
+- Debi E ' Import...
[+ Debug =
[=]- Editar jeck... BCES j I Export
- e
-~ Code Folding 1 T 2
- Cankent Assisk 1 ’
- Howers Preview:
- Mark, Occurrences -
- Save Ackions _I
- Syntax Coloring
- Task Tags
- Templates -

- Zend Framewark,
- Mew Project Lavout

- PHP Executables -
1| | B

[ Use code formatter

Restore Defaults | Apply |

©

o]

Cancel |

= 19 different templates

Insert->Header & Footer
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MySQL Is an open source database!

« MySQL download is available from
www.mysqgl.org

e Bundled with Zend Server

e Includes DB2 Storage Engine!

e Wouldn’t it be nice is you had
DFU for MySQL?

» Well, you do!!!

30 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.



http://www.mysql.org/�

phpMyAdmin

e phpMyAdmin is an open source
utility

e \Written in PHP

e Runs on nearly every platform phpMyAdmin

e Automatically installed with
Zend Server

31 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc.



phpMyAdmin

e Access form main Zend
Server dashboard

[l zend Server [ hitp:fi192.168,15.204:10...

€« C ||| ¥ hip://192.168.15.204: 10086 /ZendServer index/Index# 1283323830199 > G- &~

D Hew Tab . Zend Server Demo (T @ther bookmarks

Help | About | Logout

ol Monitor |§| Rule Management '\ Server Setup 2, Administration

Dashboard Events Jobs QUELE Statistics Code Tracing Senver Info PHP Info Logs Applications

Recent Events System Overview

Generated by Rule Count Last Occ. Severity = Origin PHP “ersion 531
Zend Framework 4 4p
Severe Slow Request Execution (Absolute) 1 07-Sep 21:57  Critical http:/192 168 .15.204: 10088/5amples/Call_Pr WErsion o

more »

Fatal PHF Error 1 02-Sep 11:27  Critical JRODPHP projectrodphp/ntdocs/CO32177 phy)
Zend Server
Database Error 1 20-Aug 11:66  Critical db2_execute
Zend Code Tracing G
Severe Slow Request Execution (Absolute) 1 13-Aug 09:35  Critical http:/A192.168.15.204: 10088/phpmyadmin/phy
Zend Data Cache  [IEXN
Database Error 2 13-Aug 09:34  Critical mysgli_guery

Zend Debugger [ on |

Zend Guard Loader [0

|

Zend Java Bridge _OFF
Learn how to start with Zend Server and PHP

Configure Zend Senver Components Zend Joh Queue [ o ]

Zend Monitor [ o~ |

Zend Optimizer+ [ on |
Zend Page Cache  [IEX

O Restart PHP

32 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. ‘
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phpMyAdmin

. Zend Server

aa PhpMyAdrmin

[ Mew Tah . Zend Server Demo

(7] hittp:ff192 168,15, 20410,

cC N v bt 192,168, 15, 204 10088/ phpmyadming

phpMyAdmin
Welcome to phpMyAdmin

~Language

|Engli5h 'I

~Login@

Username: |root

Password: |

o

> O- &

[~ other bookmarks

Insert->Header & Footer
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phpMyAdmin

. Zend Server

[ mew Tab . Zend Server Demno

phpyAdmin
AdEER

Database
[rmysgl (22) =

mysqgl (23)

B columns_priv
B db

B event

B func

B general_log

B help_category
B help_keyword

B help_relation

B help_topic

B host

B ndb_binlog_index

B plugin

B proc

B procs_priv

B seners

B slow log

B tables_priv

B time_zane

B time_zone_leap_second
B time_zone_name

B tirme_zone_transition

B time_zone_transition_type

B user

ik 192.168.15,.204:10085 { lo .,

D htkp:ff192,168,15.204:10,,, =

i Server: localhost » gy Database: mysdl

o (o | o (o (o (o (o o

L o C A | ¥¥ htp:/192.168.15 204; 10088/ phpmyadminindes phpPdb=testRitoken =a80defd 788bbase6 30b9e 5 744448296

& Structure  msSQL 'Search |[@Query #uExport Julmport $%fOperations g3 Privileges [ Drop
Table ~ Action Records! Type Collation Size
columns_priv = g % [ X 0 MyISAM U8 bin 4.0 HiB
db B #= [ X 2 MyISAM  utf8_bin 5.9 KiB
event = g %= [ X 0 MyISAM U8 _general_ci 2.0 KiB
func = g @ [ X 0 WWSAN U8 bin 1.0 KiB
general_log B #= @ X 2 CSY utfg_general_ci unknown
help_category f= #= @ X 37 MyISAM  utf8 general ci 24.0 KiE
help_keyword B = @ X 450 MISAM  UlfS general_ci 102.6 KiB
help_relation ¥ @ X 990 MYISAM LB general_ci 26.7 KiB
help_topic E=] B *= @ X S04 MyISAM  UlS general ci 428.9 KiB
host = o % [ X 0 WSANM U8 bin 2.0 KiB
ndb_binlog_index = J #= @ X o0 MyISAM  latind_swedish_ci 1.0 KiB
plugin J % @ X 0 IWSAM  ufS bin 1.0 KiB
proc - o #= [ X 0 MyISAM  utf8_general_ci 2.0 KiB
procs_priv = J % @ X 0 IWhSANM  ufS bin 4.0 KiB
servers = g # [ K 0 MyISAM  utfS_general ci 1.0 KiB
slow_log B %= @ X z SV utfs_general_ci unlknaown
tables_priv = g #F [ X 0 MyISAM  utfS_bin 4.0 KiE
time_zone = = # [ X 0 MyISAM  utf8_general_ci 1.0 KiB
time_zone_leap_second = 2 % @ X 0 MySAM  ulf8_general_ci 1.0 KiE
time_zone_name = J e @ X 0 WyISAM  uifS_general ci 1.0 KiB
time_zone_transition = B [ F M X 0 MySAM utf8_general_ci 1.0 KiB

> O- &-

[T other bookmarks

Overhead

-

34
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Zend Product Features

e Zend Server
» PHP

e Productivity features

e Monitoring

» Example scripts _
= Code Tracing
» Zend Framework

e Job Queue
» MySQL
» phpMyAdmin = 5250 Bridge
« 7Zend Studio e Data Cache and Page
Cache
» Templates _
e Studio & Server
» Debugger

Integration

36 | Insert->Header & Footer © All rights reserved. Zend Technologies, Inc. "
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COMMON 2010 - Fall Conference and Expo

« Six sessions on PHP from Zenders

» Mike Pavlak, Sam Pinkhasov, Kevin Shroeder
e More sessions by community members

» Alan Seiden, Brian may

< Visit us Iin the Zend Booth

e
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84 7end/PHP Conference

Join us at ZendCon
The premier PHP conference!

November 1-4, 2010 - San Jose, California
| | |

Conference Highlights Conference Topics

e Learn PHP best practices for architecture, design e Architecture & Design
and development e Expanding Horizons

* Technical sessions for all knowledge levels * IBMi

e Lifecycle Best Practices
e NoSQL / Alternative Stores / Search

® PHP Development
* Exhibit hall showcasing the latest products e Server/Operations

e In-depth tutorials for advanced learning
® PHP Certification courses and testing

* Networking opportunities with peers and luminaries e SQL
e Zend Framework

Wwww.zendcon.com



Great book!

Kevin Schroeder from Zend’s
Global Services Group

with helBM |
Jeff Olen, co-author of.. =i=lgle=\VIV/==4S

GUIDE to

Get yours at MCPressonline

Wt Aes

or at fine bookstores everywhere

-'g:l%ff Olen and Kevin Schroeder

. RIS AR
EED !

© All rights reserved. Zend Technologies, Inc.
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Q&A

Special thank you to Alison!

www.zend.com

mike.p@zend.com
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